How to edit some PHP text that appears on website after latest upgrade?

adrian2011 / 2018-12-08 01:50:38   

I updated php from 5.4 to 7.1. Then I updated Indexhibit and after I clicked on the yellow banner and checked the website, a text said something like this:

eir class will not be constructors in a future version of PHP; Index has a deprecated constructor in /home/adrian/public_html/ndxzsite/plugin/plugin.index.php on line 12

Warning: Cannot modify header information - headers already sent by (output started at /home/adrian/public_html/ndxzsite/plugin/plugin.index.php:12) in /home/adrian/public_html/index.php on line 166)

my website is adrianaguilera.net

Any suggestions what is causing this?

Thank you,

Vaska A / 2018-12-08 01:59:48   

I believe that you didn't upgrade /ndxzsite/plugin/plugin.index.php when you updated. Normally, you don't have to do that, but you must have been on a rather old version.

Start with that one file and see how it goes. You might find the warning notice in other areas. Also, if you haven't, you must update your exhibit formats for security reasons (I posted in the news about this earlier in the year).

And, looking at your code...disable the Indexhibit statistics plugin and then enable the New Indexhibit staticis plugin (you'll see it in the list). The old version, being based on javascript, can be blocked by adblockers.

adrian2011 / 2018-12-08 02:29:21   

Thank you for your quick answer, that resolve the issue, and yes, I found other warnings that I resolved by update one at time.

I didn't recall modify any plugins, do you recommend to update the whole plugin list? I'm still figuring it out where exhibit formats are updated, I found the information on the tutorials section, but still not sure where I update heads.

I already disable Indexhibit statistics plugin, though I don't see new Indexhibit statistics plugin.

Vaska A / 2018-12-08 12:01:34   

When you upgrade you don't have to install all of the new plugins, but it's not a bad idea. If you haven't modified your exhibit formats it's safe to replace the /ndxzsite/plugins/ folder (BACKUP YOUR SITE FIRST THOUGH). Then, you will also find the new statistics plugin.

The warning notices you saw simply had to do with changes to PHP over the years...this is why we update Indexhibit. ;)