upgarde vs. reinstall

dann02 / 2019-03-19 21:20:24   

I'm switching my hosting to DreamHost - and plan to use the newest version of indexhibit.
Will it be best to upgrade from my old version 0.70, or download and completely reinstall v2.1.5 (starting fresh with the DreamHost)?

My site is - danialnord.com/

I've been using v0.70 for years and avoiding upgrading for fear of messing things up. For example I have many pages using the 'Grow' format which I think is no longer available (?). Will I have to remake all the pages?

Vaska A / 2019-03-19 21:34:53   

Grow is available, but as Visual Index with 'grow' enabled (in Exhibit Options).

If you know how to move the database and files, upgrading shouldn't be hard. You will need to re-apply your styles, but your site is quite easy to replicate.

It's really up to you...luckily, it's easy to reload content to an Indexhibit, as well.

dann02 / 2019-03-19 22:25:33   

Thank you Jeffery.
When you say: "You will need to re-apply your styles" do you mean go into certain files and add to/tweak the code? I think I set this up about 10 years ago so I'm a bit fuzzy...

Re: "it's easy to reload content to an Indexhibit, as well."
Do you mean that if I mess up I can go back to the old content?

Also - if I set up a new database (new install) then will I lose access to my old Exhibits (Edit) @ danialnord.com/ndxz-studio/
from which I can copy/paste to the 2.15 version?
Ideally it would seem best to have the old window open to copy paste the code from each exhibit to the new version - but that may not be possible?

I appreciate your advice...

dann02 / 2019-03-19 22:31:21   

I'm sorry - I forgot to ask - If I upgrade can I upgrade directly from 0.70 to 2.15 or are there several steps between?

Vaska A / 2019-03-20 13:42:40   

Yes, there are steps...follow the directions and it should be fine. Be sure to visit each exhibit in the studio to regenerate images, too.

dann02 / 2019-03-20 18:16:40   

thank you - will do.
re: 'the directions' - do you mean under Tutorials: Upgrade to version two (actually using files from 2.15)?