Issues with Search Engine Indexing/Crawling

LauraElina / 2019-07-11 17:11:42   

Hi Everyone,

I hope I'm asking/explaining the following in a way that makes sense (and hopefully posting in the correct forum section):

I've noticed (actually a long time ago; haven't had time to address this issue) that my website, lauralarmo.com, doesn't show up in Google search anymore. Indeed it can't be found at all when searching with the URL itself.

I've talked with my website host and their support revealed to me that the robots.txt file was "missing in the root document" (it has now been created).

The second thing they said was that in the plugin.meta_tags.php the code contains NOINDEX,NOFOLLOW and that would be a problem too. I have never touched that code, I'm far from being that expert.

The question is, do I just remove the "NO-" prefix from all NOINDEX,NOFOLLOWs that I find, save, and that's it?

Are there other actions I should do?

All advice is greatly appreciated. My website used to show up in searches, usually as the first match, just when you typed "laura larmo".

Hopefully I managed to be clear!

Laura

Vaska A / 2019-07-11 19:22:03   

The meta tag plugin can change those settings - look in Plugins.

LauraElina / 2019-07-11 19:29:53   

Hi Vaska,

Many thanks for your reply. However, when I click 'Options' I only get a blank page. Do you happen to know why that happens...?

Many thanks,
Laura

Vaska A / 2019-07-11 21:09:32   

No. Perhaps your webhost has mod_security enabled and it's blocking things.

LauraElina / 2019-07-12 06:47:15   

Many thanks again. I disabled it but it didn't help. Any other advice...? Or is there some kind of timeframe until disabling mod_security takes effect?

While I was waiting yesterday for you to reply, I discovered that in many cases the solution would be removing that NOINDEX,NOFOLLOW line completely from the plugin.meta_tags.php, so I tried that. It didn't help, so I put it back—could it be that I messed something up while reapplying it...?

Vaska A / 2019-07-12 07:27:12   

If you simply delete /ndxzsite/plugin/plugin.meta_tags.php (it's called something like that) it will probably go away.

But, if you are able to manually add and remove the meta tags from the template - that means that it is hardcoded.

Vaska A / 2019-07-12 07:29:12   

Looking at your site now - it's clear that something is wrong with the file. Either you edited is incorrectly or the file was never fully uploaded. Delete it...

LauraElina / 2019-07-12 07:47:25   

Thanks again. What should I do then; reupload it? If so, where can I download the file to be uploaded? Or I just delete it and that's it?

Sorry, as usual I'm asking questions that to you must be obvious.

Vaska A / 2019-07-12 08:45:13   

Sure, reupload it and try to activate it via plugins. If it doesn't work again then it's either mod_security or you might do better by running a newer version of PHP.

I can see that you are running an older version of the template - I've never seen any issues with that, but it could be possible. You really should use the newer statistics plugin (disable the old one).

LauraElina / 2019-07-12 11:31:22   

Thanks! Sorry I still need to have this explained a bit... Do I need to disable the Meta Tags plugin first and THEN upload the file and then enable the plugin again or does it matter?

LauraElina / 2019-07-13 10:06:09   

Ok now it finally works – many thanks again. (I disabled the plugin, reuploaded the file, enabled the plugin, and that was it.) Some further questions:

1) I can see that the permissions of the plugin.meta_tags.php is now set to 0644, whereas the permissions for the other files in plugin folder are all 0755—is that normal?

2) when writing the keywords through Admin->Plugins->Meta Tags 1.0, is it "comma no space", "comma space" or "space no comma" or...?

Thanks!

Vaska A / 2019-07-13 10:54:15   

1 - if it is working don't worry about it. 644 or 755 won't affect the script functioning (if it were something else then there could be issues).

2 - comma. I recommend that you brush up on your keywords knowledge via a Google search.

3 - make sure the name on your site is in h1 tags. You can Google for ways to handle this if it's an image, etc. Also, you should put titles on every works page wrapped in h2 tags. Google LOVES h2 tags - this is no secret. Along with fixing your robots.txt and meta tags - h2 tags are the most powerful piece of SEO on your site.

4 - your site should be SSL/https - if you don't know about that ask your host how you make that happen.

5 - sign up with Google Webmaster Tools and do as they say (after you are running https).

Indexhibit is still a very simple system - the above things are free and easy and very effective. Obviously, you can't expect to be #1 for 'dance music' tags, but you can expect that people will find you by name, name of company, or a particular work, etc...

LauraElina / 2019-07-14 09:34:07   

1 - Thanks, good to know.

2 & 3 - Thanks. So far I've concentrated on my photos being keyworded and I do that in a certain phase when I'm working on my photos with a certain application that has separate fields for the keywords.
I haven't paid much attention to keywords/tags related to my website itself, also because previously just typing 'laura larmo' on Google brought this website up immediately. Now that doesn't happen which is indeed the reason I started this thread...

4 - Will do that, thanks.

5 - You mean the Google Search Console? I already did that; I learned about it like last week, and now I have to just get to know it better.

Thanks again.

LauraElina / 2019-08-16 15:13:09   

Ok the original issue continues here, but in a different way... I enabled the new statistics plug-in and disabled the old one (actually did that already weeks ago but I haven't had the chance to concentrate on this issue until now)—now the situation is that the statistics don't show any visits on my site.

That is I have 0 visits since something like mid-July; even if I visit my own site on purpose nothing shows up.

Of course the more important thing is that the site itself is up and visible to anyone but...

LauraElina / 2019-08-21 08:08:40   

An update on this, in case anyone is interested: I disabled the 'New Statistics' plugin and re-enabled the old 'Indexhibit Statistics 1.0' and voilà – I can see the page visits again.

(Of course the past month during which the 'New Statistics' was active is still a row of zeros.)

I don't know why the New Statistics didn't work for me. I also would like to mention, in case it's relevant, that in the past weeks, for a reason or another, I have cleared the cache several times.

Vaska A / 2019-08-21 08:21:51   

It probably didn't work because you never replaced the root index.php file - you have to do that for new statistics to work.

Also, the old statistics don't work as well because of adblocking (which is why I changed how they work).

LauraElina / 2019-08-21 11:27:26   

Ah I of course didn't know I should've done such thing.

I can see in my file manager that the index.php file is dated Jan 14th 2018, which is the file I downloaded when I upgraded the site last year (and that I still have also separately). Do I need to delete it and re-upload the same file again or re-download it from somewhere before re-uploading?

Thanks.