php 5.6.3 + indexhibit 2.1

KW / 2019-08-06 10:10:46   

Hello

I'm running PHP 5.6.3 and trying to install Indexhibit 2.1

When I go to mywebsite.com/indexhibit/ I get the message 'you need php 5.6 or greater'

Any help before I try installing updated PHP? Above message suggests some connection's not right that won't be fixed by installing update

Thanks in advance

KW / 2019-08-06 10:45:38   

My apologies! I realised the host server was running on 5.4 and have updated. Installation taking place now. Thanks anyway

KW / 2019-08-07 12:25:26   

I updated php but when I entered the database information I received this message:

Parse error: syntax error, unexpected '1' (T_LNUMBER) in /home2/XXXX/XXXX/XXXX/ndxzsite/config/config.php on line 5

May I please check this means I put in the wrong database password?

(I should also add that within the 'config' folder there is no file called config.php but there is 'config.example.php' and 'options.php' Can I check this is this correct?)

May I ask:

Is it possible to return to the database input form and input the correct password? If not, what course of action do you suggest?

Thank you so much

Vaska A / 2019-08-07 18:52:43   

What version of PHP are you on now? It should be 5.6.4 or greater but should really be 7.1 or greater. PHP is no longer supporting version 5...

If the config.php file is not there, then you didn't upgrade or it failed (possibly an old PHP version). You can simply create the config.php file using the config.example.php file and input the correct database info (but this is not how you upgrade).

Don't delete anything if you are upgrading...keep all the old files there...upload newest Indexhibit and then proceed to upgrade.