"you are already installed"

54meters / 2019-11-26 01:43:54   

Trying to install an indexhibit site. I'm already running an older version without any issues on the same host, different domain obviously.
Cannot get past the "you are already installed" message after filling out the database info during install.
Reinstalling/reuploading files and creating a new db didn't help.
I saw a couple other people on here with the same issue but still haven't found a solution.
Thanks

Frami / 2019-11-27 11:55:12   

Try that :

That message appears if the config file exists - /ndxzsite/config/config.php. If you wish to reinstall you must delete that file...

Source: indexhibit.org/forum/thread/15914/

54meters / 2019-12-01 14:35:11   

Thanks, already tried that but getting the same result.

srm / 2020-01-15 19:46:30   

I am having the same problem. Tried to reinstall (deleted the config file) and all seems to go well until I fill in my info and the mysql database login and hit next, then I get the message again: you are already installed.

I also tried to reset my password (see plugins) but this also did not work. I am hosting with namecheap.

Does anybody have advice for me? Many thanks!

Frami / 2020-01-19 14:45:06   

Hi,

And trying to change the prefix of the database?
by default it is ndxz_ xxxxxx, you have the choice to change it at the beginning of the installation.

In case

19rhettleinster90 / 2020-03-12 15:59:32   

hello, apologies for having to comment - i hope someone can help me. I am having the same problem here. I'm not too skilled in all the lingo but i've tried deleting and re-uploading the indexhibit files several times, and also deleting and setting up a new SQL database. I get through the set up till the database section and click continue then get this same message.
"you are already installed"
The last time i also tried a totally new database name.

When people say delete the file,
/ndxzsite/config/config.php
do they mean before you go to do the set up as per installation instructions? before doing this,
yourdomain.com/ndxzstudio/…

Or, could it be my web explorer cache?
Or should i change the prefix of the database as the last message suggested? However, in the set up this is already filled in, so by doing this do i need to do anything else?

again apologies for commenting if this is an easy fix, i've run out of solutions that i can think of.

R

19rhettleinster90 / 2020-03-13 13:05:05   

benschmidt1 posted in another thread on this issue (indexhibit.org/forum/thread/23527/) about the problem maybe being with Namecheap, who i also host with. Might anyone have a solution i can propose to Namecheap if the issue is really with them?
R

lucaremotti / 2020-09-10 20:00:20   

These things happen. I can tell you what I did: I asked my provider to erase all content and started from scratch. It was not enough to erase everything myself, because there are files, which stay there. For me it worked. I still have to update to the newest version of indexhibit and when I will, I will back up everything, included my customised stylesheet and try. Please follow this guideline here: forum.indexhibit.org/tutorials/Upgrade/upgrade-to-version-two/2/. There is everything you need to know, also to salvage your content.

jhnnssck / 2020-11-07 15:01:09   

I'm sorry, I have the same problem by setting up a completely new site (with up-to-date-contract). It just said from the beginning "you are already installed" (also changing password didn't work) ... I'm at "serverprofis"

so @lucaremotti: after erasing everything and starting again, it all worked well ? any suggestions why it worked ? (better: why did it not the first time ?)

Vaska A / 2020-11-08 10:24:04   

May I have a look at this? I would need access to the database and your studio...

Vaska A / 2020-11-09 11:13:21   

Thanks to jhnnssck for letting me look into this. It's confirmed that it's a bug (handling MariaDB). This was the first time I was able to actually see this problem.

If you have this problem (in the future) look for newer than v2.1.6 and it should be resolved. Again, I don't have funds to hire a database specialist to work on this with me - this project needs support for these kinds of problems. Please donate.