From very old version to

ovov / 2020-05-13 07:59:20   

Hello, i'm trying to update this indexhibit to a very old version (i think the 0.7 but can't find the version in any file of the backup) to the current version (v2.1.6).
I've followed the tutorial on how to upgrade without reinstall everything:
– backup the old website
– uploaded index.php, /ndxzsite/, /ndxzstudio/ as described
– run the installer and everything seems fine, he recognized the old db
– Now i can access the admin area but the front of the website gives me an error: This is the website
– I still have to update themes and exhibit formats but i can make it in a second moment, right? Actually I'm stuck because this instruction isn't clear for me:
-> Updating templates and exhibit formats
Any help?

Another thing: if i want to debug the error of the index how can i do that? I found the lines about debugging and edited as following but nothing happes:

// hide errors for the live site

// because we are backwards compatible
ini_set('display_errors', 'On');


Vaska A / 2020-05-13 08:12:06   

That error usually indicates that something is not right about your database connection. When you upgraded did it as you to import the old site? If not, you had deleted your old ndxz-studio folder from the site.

And/or, you are not running a new enough version of PHP - these days, on any decent host, they are running version 7 and newer.

ovov / 2020-05-13 09:22:07   

Yes the install told me to import the old site. As i can see from the ndxzstudio admin panel some section has been imported but there are no pages/works in it.
The website is on dreamhost, i've switched to PHP 7.2 after new installation. This could be related to the problem?

What about the debugging?

Vaska A / 2020-05-13 10:11:36   

Just comment out // those lines and you should see error messages.

How old was your site? I've seen the updater fail, but never that it took some things and not all of them. You should upgrade when you have newest PHP running. You can easily try to do the upgrade again, but use a different database prefix (it shows you on the db info page).

This upgrader has been working really well for years - there was a problem some time ago, but I fixed it. I'm a bit surprised by these problems.

ovov / 2020-05-13 14:16:38   

I think it was from 2008! It lasted so long with no problems, a real tank :)
Anyway I've tried to perform the installation again, with the php 7.2 already active. First I've deleted the new folders and uploaded them again an ran again the installer. Changed the db prefix. Everything seems fine but same error in the index.

Vaska A / 2020-05-13 15:18:08   

Did you update the index.php page to the new one?

Vaska A / 2020-05-13 15:18:56   

Is your site so vast that it's not possible to re-input things?

ovov / 2020-06-20 11:07:38   

I've solved by starting everything from scratch! Thanks

This thread has been closed, thank you.